Seite 1 von 1

Installation geht nicht - Segementation Fault

Verfasst: So 9. Jun 2019, 21:09
von Skayritares
Hallo zusammen,

Ich musste mein Server neu aufsetzen und wollte auch KeyHelp neu installieren, aber es kommt dieser Fehler:
installkeyhelp.sh: line 403: 17109 Segmentation fault php $INSTALLFILE --installer-version $INSTALLERVERSION $PASS_ARGV

Woran kann das liegen?

SORRY hab ich vergessen: Ich benutze Ubuntu 18.04

Re: Installation geht nicht - Segementation Fault

Verfasst: So 9. Jun 2019, 21:47
von OlliTheDarkness
Da gabs eine Zugriffsverletzung **weiter Begriff ich weiß**.
Aus welchem Grund MUSSTEST du den neu Aufsetzen ?

Hat irgendwas plötzlich nicht mehr getan was es sollte ?

Plötzliche abstürze ?

Sorry die Fragen , aber wäre intressant zu wissen, weil das mit ein Grund für den Fehler sein kann.

Re: Installation geht nicht - Segementation Fault

Verfasst: So 9. Jun 2019, 21:49
von Skayritares
Der Anlass der Neuinstallation war eines anderen Problems.

Ich vermute das es an Ubuntu liegt, denn ich höre das es eher Probleme gibt als bei Debian.

Re: Installation geht nicht - Segementation Fault

Verfasst: So 9. Jun 2019, 23:31
von NothingTV
Habe das gleiche Problem auf einem Ubuntu 18.04 Server.

EDIT: Ich habe gerade testweise bei Hetzner einen 18.04 und 16.04 Server angelegt. Beim 18.04 Server kommt erneut der Fehler der oben beschrieben wird und bei 16.04 funktioniert die Installation.

Re: Installation geht nicht - Segementation Fault

Verfasst: Mo 10. Jun 2019, 00:42
von sv3n
Ich habe gerade auch mal zum testen installiert. Debian 9 minimal, läuft ohne Probleme durch.

Re: Installation geht nicht - Segementation Fault

Verfasst: Mo 10. Jun 2019, 20:46
von Skayritares
Ich habe mal im Internet recherchiert und muss sagen das es doch nicht an Ubuntu 18.04 liegt, sondern eher an PHP 7.1.
Denn in dieser PHP-Version ist ein Bug, welches dieses Problem verursacht.

Bis dieser Bug behoben wurde bleib ich vorerst bei Ubuntu 16.04.

Re: Installation geht nicht - Segementation Fault

Verfasst: Di 11. Jun 2019, 10:12
von Martin
Hallo,

Ursache ist hier ein Bug in der Ioncube Loader Version von PHP 7.2. Dies tritt mit dem aktuell von Ioncube verteilten Archiv des Loaders aus. Da KeyHelp den Loader in der jeweils aktuellen Version direkt von ioncube läd ist es hier aktuell betroffen.
Ersatzweise ein älteres Archiv genommen löst das Problem.

Wir überlegen daher aktuell zukünftig den Loader auch von unserem Installationserver verteilen zu lassen, müssen aber noch prüfen inwiefern dies lizenzrechtlich möglich ist.

Re: Installation geht nicht - Segementation Fault

Verfasst: Di 11. Jun 2019, 13:02
von Skayritares
Martin hat geschrieben:
Di 11. Jun 2019, 10:12
Ersatzweise ein älteres Archiv genommen löst das Problem.
Nur wie komme ich an die älteren Archive?

Re: Installation geht nicht - Segementation Fault

Verfasst: Di 11. Jun 2019, 13:34
von Martin
Hallo,

ich habe hier einmal ein älteres Archiv erstellt:
https://install.keyweb.org/ioncube.tar

Dieses müsste dann in /usr/local entpackt werden (vorherigen alten ioncube Ordner umbennen oder löschen)
Danach kann dann die Installation mit dem Befehl welcher als letztes versucht wurde (mit vorrangestellten php) dann neu gestartet werden.

Re: Installation geht nicht - Segementation Fault

Verfasst: Di 11. Jun 2019, 14:30
von Alexander
Die Installationsroutine greift jetzt übergangsweise auf eine selbst gehostete Ioncube-Loader-Version 10.3.4 zurück.
(Die aktuelle Ioncube-Loader-Version 10.3.5 ist die problematische Version.)
KeyHelp kann nun also wieder problemlos installiert werden - "installkeyhelp.sh" muss nur erneut heruntergeladen werden.