Einen Überblick über das Administrationstool KeyHelp der Keyweb AG und dessen Download gibt es auf https://www.keyhelp.de

Dieses Forum soll es interessierten Benutzern ermöglichen, sich über KeyHelp auszutauschen und Hilfe bei Problemen zu finden.

Mailing ordentlich einrichten  [GELÖST]

Fragen zur Benutzung oder Konfiguration
nikko
Beiträge: 703
Registriert: Fr 15. Apr 2016, 16:11

Re: Mailing ordentlich einrichten

Beitrag von nikko » Do 14. Mär 2019, 23:32

Bei mir übernimmt der KH-Bind immer noch das Routen der zu jedem User vergebenen KH-Standard-Domain. Hätte keine Lust, diese auch noch alle manuell beim ext. Provider anzulegen.
Zuletzt geändert von nikko am Fr 15. Mär 2019, 00:28, insgesamt 1-mal geändert.
The software said: Requires Win Vista®, 7®, 8® or better. And so I installed Linux.
MLan
Beiträge: 67
Registriert: Mi 20. Sep 2017, 23:05

Re: Mailing ordentlich einrichten

Beitrag von MLan » Do 14. Mär 2019, 23:55

Also folgendes (nicht unübliches Szenario):

Die DNS sind beim Provider gemacht.
Die A-Records zeigen auf den KH Server und die MX Records zeigen auf einen externen Anbieter. MS, Amazonses oder weiß der Geier was.

Nehmen wir mal an, man hat einen Standard KH server aufgesetzt auf dem bind läuft.
Man hat min 1 Domain auf dem KHServer ohne eingerichtete Mailkonten.
(Ist ja nicht notwendig da ohnehin extern)

Nun schreibt zB ein Kunde über das Kontaktformular dieser Domain an kontakt@domain.de
Was denkt ihr denn was mit der Mail passiert ?


Gruß Mlan
Rainer
Beiträge: 110
Registriert: Fr 11. Mär 2016, 23:05

Re: Mailing ordentlich einrichten

Beitrag von Rainer » Fr 15. Mär 2019, 02:10

MLan hat geschrieben:
Do 14. Mär 2019, 23:55
Was denkt ihr denn was mit der Mail passiert ?
Die wird korrekt extern zugestellt, weil in den Domaineinstellungen auf dem Server die Option "Die Domain kann für E-Mail-Adressen verwendet werden" deaktiviert wurde.

Viele Grüße,
Rainer
Benutzeravatar
Tobi
Beiträge: 772
Registriert: Do 5. Jan 2017, 13:24

Re: Mailing ordentlich einrichten

Beitrag von Tobi » Fr 15. Mär 2019, 07:10

Rainer hat geschrieben:
Fr 15. Mär 2019, 02:10
MLan hat geschrieben:
Do 14. Mär 2019, 23:55
Was denkt ihr denn was mit der Mail passiert ?
Die wird korrekt extern zugestellt, weil in den Domaineinstellungen auf dem Server die Option "Die Domain kann für E-Mail-Adressen verwendet werden" deaktiviert wurde.

Viele Grüße,
Rainer
Jupp. Genau so und garantiert nicht anders geht das mit dem Mail versenden.

Funktioniert das denn bei dir nicht MLan?
Gruß,
Tobi



https://wewoco.de
webworkercommunity forum
MLan
Beiträge: 67
Registriert: Mi 20. Sep 2017, 23:05

Re: Mailing ordentlich einrichten

Beitrag von MLan » Fr 15. Mär 2019, 10:19

Tobi hat geschrieben:
Fr 15. Mär 2019, 07:10
Funktioniert das denn bei dir nicht MLan?
Moin Männer,

nein das funktioniert so nicht.
da zuerst der locale bind befragt wird, wie der MX Eintrag dür diese domain ist.
Und da kommt ja dann mail.domain.de = KHServer IP (standardeinstellung)
Egal ob man was am DNS Editor von KH gemacht hat oder nicht.
Damit wird die Mail versucht local zuzustellen, was natürlich fehlschlagen muß.

Gruß Mlan
Rainer
Beiträge: 110
Registriert: Fr 11. Mär 2016, 23:05

Re: Mailing ordentlich einrichten

Beitrag von Rainer » Fr 15. Mär 2019, 10:41

Hallo Mlan,
MLan hat geschrieben:
Fr 15. Mär 2019, 10:19
nein das funktioniert so nicht.
da zuerst der locale bind befragt wird, wie der MX Eintrag dür diese domain ist.
nein, wenn Du die Option "Die Domain kann für E-Mail-Adressen verwendet werden" deaktivierst, wird eben nicht mehr lokal gesucht. Deswegen gibt's diese Option.

Hast Du's bei Dir mal ausprobiert?

Viele Grüße,
Rainer
derFu
Beiträge: 26
Registriert: Sa 28. Apr 2018, 18:46

Re: Mailing ordentlich einrichten

Beitrag von derFu » Fr 15. Mär 2019, 12:15

Rainer hat geschrieben:
Fr 15. Mär 2019, 10:41
Hallo Mlan,
MLan hat geschrieben:
Fr 15. Mär 2019, 10:19
nein das funktioniert so nicht.
da zuerst der locale bind befragt wird, wie der MX Eintrag dür diese domain ist.
nein, wenn Du die Option "Die Domain kann für E-Mail-Adressen verwendet werden" deaktivierst, wird eben nicht mehr lokal gesucht. Deswegen gibt's diese Option.

Hast Du's bei Dir mal ausprobiert?

Viele Grüße,
Rainer

Ich muss Mlan mal beipflichten, bei mir ist es auch so, dass die Mail nicht zugestellt wird, wenn ich nicht den NS in die Domainzone eintrage.

Szenario:
Sender-Domain example.de ist in KeyHelp angelegt, Sender-Postfach ist auf KeyHelp-Server eingerichtet.

Empfänger Domain example.com: ist ebenfalls im KeyHelp angelegt, Postfach bei anderem Anbieter, NS ist extern, MX dort zeigt auf den anderen Anbieter, Haken bei "Die Domain kann für E-Mail-Adressen verwendet werden" ist nicht und war nie gesetzt, DNS-Zone für die Domain im KeyHelp ist unberührt

Bei Mail von example.de an example.com gibt es
Action: failed
Status: 5.4.6
Diagnostic-Code: X-Postfix; mail for example.com loops back to myself
Erst wenn ich im KeyHelp bei example.com den externen Nameserver in die DNS-Zone im Keyhelp eintrage, wird die Mail beim externen Anbieter zugestellt.

Das ganze auf Debian 9 auf einem von KeyWeb eingerichteten Server.

Prinzipiell ist mir das wurscht, trage ich halt die NS in die DNS-Zone ein, aber ein generelles "Nein, gibt keine Probleme" scheint nicht zu gelten.
Viele Grüße,

Thorsten
Benutzeravatar
Tobi
Beiträge: 772
Registriert: Do 5. Jan 2017, 13:24

Re: Mailing ordentlich einrichten

Beitrag von Tobi » Fr 15. Mär 2019, 12:45

Rainer hat geschrieben:
Fr 15. Mär 2019, 10:41
wenn Du die Option "Die Domain kann für E-Mail-Adressen verwendet werden" deaktivierst, wird eben nicht mehr lokal gesucht.
Jupp, genau so ist es.
Der Haken muss raus, dann geht auch die E-Mail raus.
Gruß,
Tobi



https://wewoco.de
webworkercommunity forum
MLan
Beiträge: 67
Registriert: Mi 20. Sep 2017, 23:05

Re: Mailing ordentlich einrichten

Beitrag von MLan » Fr 15. Mär 2019, 13:02

Tobi hat geschrieben:
Fr 15. Mär 2019, 12:45
Rainer hat geschrieben:
Fr 15. Mär 2019, 10:41
wenn Du die Option "Die Domain kann für E-Mail-Adressen verwendet werden" deaktivierst, wird eben nicht mehr lokal gesucht.
Jupp, genau so ist es.
Der Haken muss raus, dann geht auch die E-Mail raus.
Nein,
Es ist vollkommen egal ob du das da anhakst oder nicht.
da nach wie vor der falsche MX vom localen bind zurückgegeben wird.
Ich hoffe wir reden hier nicht aneinander vorbei :)
Gruß Mlan
ShortSnow
Beiträge: 23
Registriert: Do 15. Nov 2018, 00:45

Re: Mailing ordentlich einrichten

Beitrag von ShortSnow » Fr 15. Mär 2019, 13:13

Hallo MLan,

ich verstehe Dich. Hab das selbe Problem. Hab dazu statt Bind zu deaktivieren, einfach in der Bund Conf den Include für den Keyhelp Ordner entfernt.

Das Problem tritt auf bei folgendem Aufbau:

-Externer Mailserver
-Externes DNS
-Mails die dann von Scripten per phpmail gesendet werden und kein SMTP nutzen und an eine auf den gleichen Server liegende Domain gesendet werden.

Und natürlich Standard DNS Einstellungen im Keyhelp. Wenn man da manuell den externen MX zusätzlich einträgt. Ist das Problem auch schon wieder gelöst...

Gruß ShortSnow
Rainer
Beiträge: 110
Registriert: Fr 11. Mär 2016, 23:05

Re: Mailing ordentlich einrichten

Beitrag von Rainer » Fr 15. Mär 2019, 14:27

Hallo,

bei mir funktioniert's (gerade beide Fälle getestet) wie von mir beschrieben. Am internen DNS wurden keine Änderungen vorgenommen. Aber: Ich hatte leider vergessen, dass ich die resolv.conf einst angepasst hatte. Sorry. Dort hatte ich u.a. die 127.0.0.1 entfernt.

Viele Grüße,
Rainer
hase
Beiträge: 199
Registriert: Fr 29. Sep 2017, 16:18

Re: Mailing ordentlich einrichten

Beitrag von hase » Fr 15. Mär 2019, 17:00

Sehr komisch alles mit bind :?
Das erste was ich gemacht habe nachdem der Server eingerichtet war, den bind deaktiviert, und bisher keine Probleme damit. Auch keine confs geändert, alles original KH. Laut den Logfiles gibts auch keine Probleme wie ihr hier beschreibt...

Eigentlich dürfte bind gar nicht von beginn aktiviert werden, sondern nur optional wenn man eigene NS nutzt.
viele Grüße
Andi
MLan
Beiträge: 67
Registriert: Mi 20. Sep 2017, 23:05

Re: Mailing ordentlich einrichten

Beitrag von MLan » Fr 15. Mär 2019, 18:27

hase hat geschrieben:
Fr 15. Mär 2019, 17:00
Eigentlich dürfte bind gar nicht von beginn aktiviert werden, sondern nur optional wenn man eigene NS nutzt.
Das ist ja meine Rede seit gefühlten 50 Postings.
Am besten bind disablen und maskieren, damit der beim nächten panelupdate nicht wieder gestartet wird, wenn man den DNS vom Provider nutzt.

Gruß Mlan
hase
Beiträge: 199
Registriert: Fr 29. Sep 2017, 16:18

Re: Mailing ordentlich einrichten

Beitrag von hase » Fr 15. Mär 2019, 18:52

Würde gerne mal eine Meinung vom KH-Entwickler dazu lesen :)
viele Grüße
Andi
Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 6 Gäste