Einen Überblick über das Administrationstool KeyHelp der Keyweb AG und dessen Download gibt es auf https://www.keyhelp.de

Dieses Forum soll es interessierten Benutzern ermöglichen, sich über KeyHelp auszutauschen und Hilfe bei Problemen zu finden.

Local resolving checks failed for domain  [GELÖST]

Fehler gefunden? Bitte hier melden.
Benutzeravatar
Alexander
Keyweb AG
Beiträge: 1772
Registriert: Mi 20. Jan 2016, 02:23

Re: Local resolving checks failed for domain

Beitrag von Alexander »

Blackmoon hatte ein spezielles Setup.

"Local resolving checks failed for domain"

heißt erstmal nur, das deine Domain lokal nicht aufgelöst werden konnte, die Domain zeigt nicht auf den Server o.Ä. Überprüfe einmal die lokale Namensauflösung auf dem Server mittels, z.b. curl / wget usw...
Mit freundlichen Grüßen / Best regards
Alexander Mahr

**************************************************************
Keyweb AG - Die Hosting Marke
Neuwerkstr. 45/46, 99084 Erfurt / Germany
http://www.keyweb.de - http://www.keyhelp.de
**************************************************************
webserviceraidt
Beiträge: 6
Registriert: Mo 16. Dez 2019, 09:29

Re: Local resolving checks failed for domain

Beitrag von webserviceraidt »

Hallo lieber Keyhelp Community,

ich bin hier neu im Forum und habe scheinbar das gleiche Problem auf meiner keyhelp Installation.

Was ich feststellen konnte, ist das, wenn ich die http auf HTTPS Umleitung in den Domaineinstellungen einschalte es nicht mehr funktioniert. Schalte ich diese aus lässt sich das Zertifikat ohne Probleme aktualisieren.

Führe ich bei aktiver HTTPS Umleitung der Domain über wget ein Download der Challenge über die Shell aus bricht dieser ab da er auf HTTPS umgeleitet wird (siehe Screenshot)

Bild

Bei ausgeschalteter Umleitung funktioniert es einwandfrei.

Ich habe in einem anderen Forumsbeitrag gelesen das man unter den Apache-Einstellungen der Domain folgendes eingeben soll, um diesem Problem zu entgehen

<IfModule mod_proxy.c>
ProxyPass /.well-known/acme-challenge !
</IfModule>

Alias /.well-known/acme-challenge /home/keyhelp/www/.well-known/acme-challenge

ProxyPass / http://127.0.0.1:27876/
ProxyPassReverse / http://127.0.0.1:27876/
Leider bringt mich dies nicht weiter. Er trägt zwar alles sauber ein die Aktualisierung des Zertifikats funktioniert trotzdem nicht. Fehler ist weiterhin wie oben auf dem Screenshot.

Zur Info:

Im Serverlog erhalte ich folgenden Fehler:
a lets encrypt error occurred for domain "bla.test.de"
im SSL Log erhalte ich den folgenden Fehler:
[04-Jan-2020 00:03:09] ERROR --> a lets encrypt error occurred: Local resolving checks failed for domain "bla.test.de".
Ich hoffe, mir kann hier jemanden helfen mein Problem zu lösen? Ich danke schonmal im vor raus für die Hilfe.

Gruß
Blackmoon
Beiträge: 250
Registriert: Sa 1. Dez 2018, 16:42

Re: Local resolving checks failed for domain

Beitrag von Blackmoon »

Hallo.
Die Zeile

Code: Alles auswählen

Alias /.well-known/acme-challenge /home/keyhelp/www/.well-known/acme-challenge
kannst du löschen.

Die Zeilen

Code: Alles auswählen

<IfModule mod_proxy.c>
ProxyPass /.well-known/acme-challenge !
</IfModule>
durch

Code: Alles auswählen

ProxyPass /.well-known !
ersetzen. Anschließend nochmals probieren.

Gruß
webserviceraidt
Beiträge: 6
Registriert: Mo 16. Dez 2019, 09:29

Re: Local resolving checks failed for domain

Beitrag von webserviceraidt »

Hallo Blackmoon,

danke für die Tipps.

Ich hab die Zeilen jetzt angepasst leider ohne Änderung. Ich bekomme immer noch die gleichen Fehler.

Nur damit ich nichts falsch gemacht habe. Die Zeilen müssen unter folgendem Punkt eingetragen werden richtig?

Bild

Gruß
Benutzeravatar
Justman10000
Beiträge: 101
Registriert: Di 15. Dez 2020, 16:40

Re: Local resolving checks failed for domain

Beitrag von Justman10000 »

Blackmoon hat geschrieben: So 1. Dez 2019, 20:57 Wir haben selbstverständlich auch unsere ssl.conf entsprechend angepasst. Auf Grund deines Hinweises, wollte ich schon mit den Änderungen beginnen. Allerdings habe ich nochmals ein manuell Wartung der Zertifikate gestartet und siehe da, alle Zertifikate wurden problemlos verlängert.

Puh... lag es nun an KeyHelp oder LE?

/Dani
Wo ist denn die ssl.conf?
Antworten