Einen Überblick über das Administrationstool KeyHelp der Keyweb AG und dessen Download gibt es auf https://www.keyhelp.de

Dieses Forum soll es interessierten Benutzern ermöglichen, sich über KeyHelp auszutauschen und Hilfe bei Problemen zu finden.

Antiviren Scanner schlägt fehl  [GELÖST]

Fehler gefunden? Bitte hier melden.
Antworten
Benutzeravatar
Nick1307
Beiträge: 3
Registriert: Di 20. Feb 2018, 15:34

Antiviren Scanner schlägt fehl

Beitrag von Nick1307 »

Hallo zusammen,

ich bin dabei für einen Freund einen vServer mit Keyhelp zu installieren, doch irgendetwas stimmt mit ClamAV nicht...
Zunächst ist ClamAV extra für diesen Testzweck auf einen täglichen Scan zwischen 1 und 2 Uhr eingestellt. Doch diesen hat er letzte Nacht nicht gemacht. Das Hauptproblem ist jedoch, dass der Scan zwar anscheinend läuft, jedoch die Ergebnisse nicht übergibt... Siehe angehängten Bild "ClamAV.png"... Der Scan läuft halt im Hintergrund 10 Minuten...

Zu den Logs:
Im install.log finden sich keine Fehler, alles wurde reibungslos installiert... Der avscan.log sieht so aus:

Code: Alles auswählen

====
[18-May-2018 17:34:01] INFO  --> start av scanner
[18-May-2018 17:38:44] ERROR --> av scanner failed: "Abort, anti virus scanner failed."
[18-May-2018 17:38:44] INFO  --> av scanner report:
------------- AV SCAN --------------
Start: 2018-05-18 17:34:01
 ---------- SCAN LOCATIONS ----------
/
------ UPDATE VIRUS DATABASE -------
Start: 2018-05-18 17:34:01
End: 2018-05-18 17:34:02
Status: Success
--------------- END ----------------
End: 2018-05-18 17:38:44
Status: Abort, anti virus scanner failed.
====
System: Als vServer wird der CX11 von Hetzner verwendet.
Vorgehensweise:
1) Server angelegt & in das Rescue-System von Hetzner gebootet & manuell Ubuntu 18.04 LTS (minimal) installiert
2) Subdomain auf Server-IP geroutet & gewartet
3) Nach den Reboot alle Updates gezogen & Hostnamen /etc/host und /etc/hostname kontrolliert
4) Noch ein Reboot & KH 18.1 installiert... (fehlerfrei)
5) Grundeinstellungen in KH vorgenommen

Nebenbemerkung:
Bei den zusätzlichen PHP-Versionen (unter Panel-Einstellungen) findet sich nur die Fehlermeldung
"Oh no, our repository server is currently not available.
We are going to fix this problem ASAP!
(Failed to contact repo server. "Repository error, repository not found")"...
Vielleicht hilft euch diese Information etwas weiter...

Ich hab in den vergangenen Tagen den Server mehrfach neu aufgesetzt und immer wieder das gleiche Problem, wobei die PHP-Meldung neu ist...
Zu Testzwecken habe ich auch Ubuntu 16.04 getestet, wobei dies dort vereinzelt auch auftritt, bzw. manchmal der erste fehlschlägt und folgende ClamAV Scans erfolgreich waren... Da ich in den Logs keine Fehler oder sonst etwas finden kann, steh ich gerade richtig auf den Schlauch...
Ich hoffe ihr könnt mir da etwas weiterhelfen...

Mit freundlichen Grüßen
Nick1307
Dateianhänge
ClamAV.png
nikko
Beiträge: 877
Registriert: Fr 15. Apr 2016, 16:11

Re: Antiviren Scanner schlägt fehl

Beitrag von nikko »

Hm....da stehe ich gerade auch aufm Schlauch. Mit 18.04 würde ich eh noch warten. Viel zu früh. Hier gibt's noch dann und wann Ärger, da einige Pakete noch nicht zu 100% laufen.

Setze doch 16.04 auf und wenn die Kiste läuft, dann läuft sie. Es gibt irgendwann ein Updatescript auf 18.04. , was dann den Umstieg problemlos durchführt.

Aber dann ist die Sache soweit stable, dass es auch funktioniert.

Meine letzten beiden Server sind immer noch bei 14.04. :D
The software said: Requires Win Vista®, 7®, 8® or better. And so I installed Linux.
Benutzeravatar
Nick1307
Beiträge: 3
Registriert: Di 20. Feb 2018, 15:34

Re: Antiviren Scanner schlägt fehl

Beitrag von Nick1307 »

Das Problem ist...
auch in 16.04 taucht mein Problem auf... Wie gesagt hatte ich das mit 16.04 auch getestet... gleicher Server... nur in 1 von 3 Fällen funktionierte der Virenscanner... Bei den anderen 2 malen ist es wie in 18.04....

Mit freundlichen Grüßen
Nick1307
nikko
Beiträge: 877
Registriert: Fr 15. Apr 2016, 16:11

Re: Antiviren Scanner schlägt fehl

Beitrag von nikko »

OK, dann los...
Mach mal die Kiste schick mit 16.04 fertig. Wenn sie läuft, richtest du dir den Server im Adminbereich auf allen Seiten vernünftig ein. Mit Mailadresse hinterlegen, User anlegen (User bekommt Freischaltmail), Domain anlegen, SSL abrufen - na halt komplett. (Damit will ich nur sehen, ob irgendetwas anderes auch nicht funktioniert)
Danach startest du mal alle Serveraufgaben manuell, nur den Virenscanner nicht - und wartest deren Durchlauf ab.

Wenn bis hierher noch alles gut ist, starte mal den Virenscanner (achte auf die Uhrzeit).

Dein erster Partner bei der Fehlersuche ist das error.log und sys.log im Verzeichnis /var/log/. Hier solltest du erste Meldungen zur betreffenden Uhrzeit finden. Ggfls existiert keine error.log. Weiteres sollte sich dann u.U. auch in /var/log/clamav/clamav.log finden.
The software said: Requires Win Vista®, 7®, 8® or better. And so I installed Linux.
Benutzeravatar
Alexander
Keyweb AG
Beiträge: 1844
Registriert: Mi 20. Jan 2016, 02:23

Re: Antiviren Scanner schlägt fehl

Beitrag von Alexander »

Bei den zusätzlichen PHP-Versionen (unter Panel-Einstellungen) findet sich nur die Fehlermeldung
"Oh no, our repository server is currently not available.
We are going to fix this problem ASAP!
(Failed to contact repo server. "Repository error, repository not found")"...
Vielleicht hilft euch diese Information etwas weiter...
Die zusätzlichen PHP-Interpreter für Ubuntu 18 folgen erst in der kommenden Woche, Aktuell kommt die Meldung, weil das Repository für diese Versionen noch nicht existiert. Das ist also normal.

Das Clam-Problem:

du könntest einmal den Scan manuell starten und schauen, ob noch weitere Fehlermeldungen ausgespruckt werden:

Code: Alles auswählen

clamscan <VERZEICHNIS>
Mit freundlichen Grüßen / Best regards
Alexander Mahr

**************************************************************
Keyweb AG - Die Hosting Marke
Neuwerkstr. 45/46, 99084 Erfurt / Germany
http://www.keyweb.de - http://www.keyhelp.de
**************************************************************
Benutzeravatar
Nick1307
Beiträge: 3
Registriert: Di 20. Feb 2018, 15:34

Re: Antiviren Scanner schlägt fehl

Beitrag von Nick1307 »

Okay... Ich denke ich hab das Problem gefunden... Und es lag anscheinend nicht an Keyhelp oder mir... Mein Freund hatte die zu untersuchende Verzeichnisse auf "/" gesetzt...
Ich hab nun mit den Standart-Einstellungen alles nochmal getestet & es funktioniert alles einwandfrei. Nach Rücksprache mit ihm hat er mir erklärt, dass er möglichst alles scannen möchte... Ein manueller Scan mit "clamscan -i -r / > /root/clamscan.log" bringt nebenbei auch folgende Fehlermeldung (gekürtzt):

Code: Alles auswählen

WARNING: Can't open file /sys/bus/clocksource/uevent: Permission denied
LibClamAV Warning: fmap_readpage: pread fail: asked for 4094 bytes @ offset 2, got 0
WARNING: Can't open file /sys/bus/hid/drivers_probe: Permission denied
[...und so weiter...]
Fehler ist wohl eine unzureichende Berechtigung in /sys .
Da er auf einen möglichst kompletten Scan besteht, stellt sich nun die Frage, macht nur /sys solche Probleme? Oder gibt es noch mehr Ordner, wo Clam nicht lesen kann?

Mit freundlichen Grüßen
Nick1307
nikko
Beiträge: 877
Registriert: Fr 15. Apr 2016, 16:11

Re: Antiviren Scanner schlägt fehl

Beitrag von nikko »

Ja. Es muss nicht alles gescannt werden. KH hat ein gut durchdachtes Sicherheitskonzept und scannt die Pfade, die primäre Einfalltore sind, nämlich ungepflegte Userscripte.
The software said: Requires Win Vista®, 7®, 8® or better. And so I installed Linux.
Benutzeravatar
Martin
Community Moderator
Beiträge: 974
Registriert: Mi 20. Jan 2016, 00:43

Re: Antiviren Scanner schlägt fehl

Beitrag von Martin »

Hallo,

bei /sys und auch /dev handelt es sich um Geräteverzeichnisse, hier sind keine Dateien als solches vorhanden sondern größtenteils virtuelle Gerätedateien etc..
In /dev z.B. /dev/urandom etc.

Das es hier bei einem normalen Dateiscan Fehlermeldungen gibt wäre daher durchaus zu erwarten.
Viele Grüße,
Martin
mfeicht
Beiträge: 37
Registriert: Fr 8. Mär 2019, 09:24

Re: Antiviren Scanner schlägt fehl

Beitrag von mfeicht »

Hallo zusammen,

ich habe ein ähnliches Problem. Wenn ich den Virenscan über KeyHelp starte, bekomme ich die Meldung per E-Mail "Abort, anti virus scanner failed.".

Deshalb habe ich versucht den Virenscan über

Code: Alles auswählen

clamscan <VERZEICHNIS>
zu starten und so ggf. an eine Fehlermeldung o. ä. zu kommen. Das hat auch funktioniert.

Standardmäßig werden von KeyHelp bei mir die Verzeichnisse "/home/users", "/var" und "/var/tmp" gescannt. Der manuell scann von "/home/users" funktioniert problemlos. Bei den anderen beiden Verzeichnissen bekomme ich in der Konsole allerdings immer nach ein paar Sekunden die Meldung "Killed". Woran kann das liegen?
Benutzeravatar
Alexander
Keyweb AG
Beiträge: 1844
Registriert: Mi 20. Jan 2016, 02:23

Re: Antiviren Scanner schlägt fehl  [GELÖST]

Beitrag von Alexander »

Dadurch, das Clamscan also auch ohne KeyHelp fehlschlägt, liegt die Ursache dafür also nicht unbedingt an KeyHelp.
Hierzu einmal die Google-Suche bemühen, bei "clamscan + killed" ließen sich einige Einträge hierzu für die Fehlersuche finden, verbose flags etc.
Ggf. sind die tmp-Verzeichnisse auch anders gemountet und das bringt ggf. clamscan aus dem Tritt.
Mit freundlichen Grüßen / Best regards
Alexander Mahr

**************************************************************
Keyweb AG - Die Hosting Marke
Neuwerkstr. 45/46, 99084 Erfurt / Germany
http://www.keyweb.de - http://www.keyhelp.de
**************************************************************
mfeicht
Beiträge: 37
Registriert: Fr 8. Mär 2019, 09:24

Re: Antiviren Scanner schlägt fehl

Beitrag von mfeicht »

Alexander hat geschrieben: Mi 9. Jun 2021, 13:41 Dadurch, das Clamscan also auch ohne KeyHelp fehlschlägt, liegt die Ursache dafür also nicht unbedingt an KeyHelp.
Hierzu einmal die Google-Suche bemühen, bei "clamscan + killed" ließen sich einige Einträge hierzu für die Fehlersuche finden, verbose flags etc.
Ggf. sind die tmp-Verzeichnisse auch anders gemountet und das bringt ggf. clamscan aus dem Tritt.
Das war die Lösung. Das Problem war, dass auf dem Server zu wenig RAM für den Virenscan verfügbar war. Jetzt habe ich den RAM von 2GB auf 4GB erweitert und schon funktioniert alles problemlos.

Danke für den Tipp!
Antworten