Installer startet nicht?  [GELÖST]

Fragen und Probleme mit der Installation
User avatar
Jolinar
Community Moderator
Posts: 2177
Joined: Sat 30. Jan 2016, 07:11
Location: Weimar (Thüringen)
Contact:

Re: Installer startet nicht?

Post by Jolinar »

Pflegecraft wrote: Fri 29. Apr 2022, 20:25 Damit hat es nun funktioniert...
Keine Ahnung was an dem Server falsch läuft... sehr komisch... Ich danke euch aufjedenfall für die schnelle Hilfe.
Du hast aber aktuell nur die Auswirkungen kaschiert...das Problem ist ja immer noch da.
Und wenn dein Server Zertifikate nicht als vertrauenswürdig bzw. als abgelaufen erkennt, dann wirst du früher oder später wieder über dasselbe Problem stolpern.
Wenn jemand inkompetent ist, dann kann er nicht wissen, daß er inkompetent ist. (David Dunning)
___
Ich verwende in meinen Beiträgen zwei verschiedene Schriftfarben:
  • In dieser Farbe schreibe ich als Moderator und gebe moderative Hinweise oder begründe moderative Eingriffe
  • In dieser Farbe schreibe ich als Mitglied der Community und teile meine private Meinung und persönlichen Ansichten mit
User avatar
Pflegecraft
Posts: 39
Joined: Mon 2. Aug 2021, 16:26
Location: Salzgitter (Niedersachsen)
Contact:

Re: Installer startet nicht?

Post by Pflegecraft »

Jolinar wrote: Fri 29. Apr 2022, 20:19 Was du vorher vielleicht nochmal probieren könntest:

Code: Select all

apt-get install --reinstall ca-certificates
update-ca-certificates --fresh
Vielleicht hat sich in der Zertifikatsverwaltung was verklemmt.
Nein also bei den beiden Befehlen haut es trotzdem nicht hin kommt die selbe Fehlermeldung mit den Zertifikaten....
Wieso auch immer das dort passiert.... Vlt. Hoster seitiges Problem. ist eine KVM maschine in Falkenstein (Hetzner) wird von Prepaid-Hoster verwaltet...
ist eine Minimal Install Debian 11
User avatar
Jolinar
Community Moderator
Posts: 2177
Joined: Sat 30. Jan 2016, 07:11
Location: Weimar (Thüringen)
Contact:

Re: Installer startet nicht?

Post by Jolinar »

Welches OS kommt eigentlich zum Einsatz?
Wenn jemand inkompetent ist, dann kann er nicht wissen, daß er inkompetent ist. (David Dunning)
___
Ich verwende in meinen Beiträgen zwei verschiedene Schriftfarben:
  • In dieser Farbe schreibe ich als Moderator und gebe moderative Hinweise oder begründe moderative Eingriffe
  • In dieser Farbe schreibe ich als Mitglied der Community und teile meine private Meinung und persönlichen Ansichten mit
User avatar
Pflegecraft
Posts: 39
Joined: Mon 2. Aug 2021, 16:26
Location: Salzgitter (Niedersachsen)
Contact:

Re: Installer startet nicht?

Post by Pflegecraft »

Es ist ein Debian 11 habe vom Hoster nur ein Image und kann keine eigenen installieren ist auch laut ihm ein Minimal Install habe ebend nachgefragt.
User avatar
Jolinar
Community Moderator
Posts: 2177
Joined: Sat 30. Jan 2016, 07:11
Location: Weimar (Thüringen)
Contact:

Re: Installer startet nicht?

Post by Jolinar »

Eventuell ein Rechteproblem?
Was sagt

Code: Select all

ls -al /etc/ssl
Wenn jemand inkompetent ist, dann kann er nicht wissen, daß er inkompetent ist. (David Dunning)
___
Ich verwende in meinen Beiträgen zwei verschiedene Schriftfarben:
  • In dieser Farbe schreibe ich als Moderator und gebe moderative Hinweise oder begründe moderative Eingriffe
  • In dieser Farbe schreibe ich als Mitglied der Community und teile meine private Meinung und persönlichen Ansichten mit
User avatar
Pflegecraft
Posts: 39
Joined: Mon 2. Aug 2021, 16:26
Location: Salzgitter (Niedersachsen)
Contact:

Re: Installer startet nicht?

Post by Pflegecraft »

Dies gibt folgende Ausgabe;

Code: Select all

total 40
drwxr-xr-x  4 root root  4096 Apr 29 14:33 .
drwxr-xr-x 70 root root  4096 Apr 29 14:34 ..
drwxr-xr-x  2 root root 16384 Apr 29 14:35 certs
-rw-r--r--  1 root root 11118 May 30  2019 openssl.cnf
drwx------  2 root root  4096 May 30  2019 private
User avatar
Jolinar
Community Moderator
Posts: 2177
Joined: Sat 30. Jan 2016, 07:11
Location: Weimar (Thüringen)
Contact:

Re: Installer startet nicht?

Post by Jolinar »

Okay, das sieht soweit gut aus.

Hmm...So langsam gehen mir die Ideen aus. :(

Schau mal bitte, ob wget in der aktuellsten Version vorliegt

Code: Select all

apt upgrade wget
Wenn jemand inkompetent ist, dann kann er nicht wissen, daß er inkompetent ist. (David Dunning)
___
Ich verwende in meinen Beiträgen zwei verschiedene Schriftfarben:
  • In dieser Farbe schreibe ich als Moderator und gebe moderative Hinweise oder begründe moderative Eingriffe
  • In dieser Farbe schreibe ich als Mitglied der Community und teile meine private Meinung und persönlichen Ansichten mit
User avatar
Tobi
Community Moderator
Posts: 1983
Joined: Thu 5. Jan 2017, 13:24

Re: Installer startet nicht?

Post by Tobi »

Du könntest das Zertifikat mal lokal testen.
https://docs.pingidentity.com/bundle/so ... 23079.html
Gruß,
Tobi


-----------------------------
wewoco.de
Das Forum für Reseller, Digital-Agenturen, Bildschirmarbeiter und Mäuseschubser
trollolol
Posts: 108
Joined: Wed 18. Sep 2019, 10:18
Location: Eisenach

Re: Installer startet nicht?

Post by trollolol »

Was mir in dem Zusammenhang einfällt: wenn du als Root eingeloggt bist bist mach mal ein "su -" und versuch das ganze nochmal.

Bin auch bei Hetzner :)
User avatar
24unix
Posts: 518
Joined: Sun 21. Jun 2020, 17:16
Location: Kollmar
Contact:

Re: Installer startet nicht?

Post by 24unix »

trollolol wrote: Sat 30. Apr 2022, 11:11 Was mir in dem Zusammenhang einfällt: wenn du als Root eingeloggt bist bist mach mal ein "su -" und versuch das ganze nochmal.

Bin auch bei Hetzner :)
Was soll das bringen? Mit "id" sieht man die effektiven Rechten, root ist root, auch bei hetzner :)
Use secondary nameservers with Keyhelp: https://24unix.net/projects/bindAPI
Supports DynDNS, documentation will be updated soon.

Are you looking for a PHP coder?
Or maybe a UNIX/Linux admin? I'm available for hire.
trollolol
Posts: 108
Joined: Wed 18. Sep 2019, 10:18
Location: Eisenach

Re: Installer startet nicht?

Post by trollolol »

24unix wrote: Sat 30. Apr 2022, 11:24
trollolol wrote: Sat 30. Apr 2022, 11:11 Was mir in dem Zusammenhang einfällt: wenn du als Root eingeloggt bist bist mach mal ein "su -" und versuch das ganze nochmal.

Bin auch bei Hetzner :)
Was soll das bringen? Mit "id" sieht man die effektiven Rechten, root ist root, auch bei hetzner :)
Kann ich nicht bestätigen. Es ist ein Unterschied ob ich nur mit "su" versuche (bei mir in dem Fall Java) zu installieren oder mit "su -"
Da gab es auch Probleme mit den Zertifikaten. Erst nachdem ich ein "su -" eingegeben habe lief die Installaton von Java sauber durch.
User avatar
Pflegecraft
Posts: 39
Joined: Mon 2. Aug 2021, 16:26
Location: Salzgitter (Niedersachsen)
Contact:

Re: Installer startet nicht?  [GELÖST]

Post by Pflegecraft »

Ich habe es hinbekommen musste den Server einmal komplett durch updaten.
apt-get update && apt-get upgrade und danach noch ein apt-get dist-upgrade
ohhman so einfach und doch so komplex die Fehlermeldung....

Ich danke euch trotzdem für die tolle Hilfe...
User avatar
Jolinar
Community Moderator
Posts: 2177
Joined: Sat 30. Jan 2016, 07:11
Location: Weimar (Thüringen)
Contact:

Re: Installer startet nicht?

Post by Jolinar »

Pflegecraft wrote: Sun 1. May 2022, 10:15 Ich habe es hinbekommen musste den Server einmal komplett durch updaten.
apt-get update && apt-get upgrade und danach noch ein apt-get dist-upgrade
Naja...nicht allein dein Fehler :lol:
Ich hätte am Anfang auch nachfragen können, ob du die initiale Systemaktualisierung durchgeführt hast...Aber ich bin schon so lange auf Servern unterwegs, daß ich das oft einfach voraussetze und nicht explizit noch mal nachfrage.
Ich werde mich zukünftig bemühen, diesen Punkt zu berücksichtigen 8-)
Wenn jemand inkompetent ist, dann kann er nicht wissen, daß er inkompetent ist. (David Dunning)
___
Ich verwende in meinen Beiträgen zwei verschiedene Schriftfarben:
  • In dieser Farbe schreibe ich als Moderator und gebe moderative Hinweise oder begründe moderative Eingriffe
  • In dieser Farbe schreibe ich als Mitglied der Community und teile meine private Meinung und persönlichen Ansichten mit
User avatar
24unix
Posts: 518
Joined: Sun 21. Jun 2020, 17:16
Location: Kollmar
Contact:

Re: Installer startet nicht?

Post by 24unix »

trollolol wrote: Sun 1. May 2022, 09:19
24unix wrote: Sat 30. Apr 2022, 11:24
trollolol wrote: Sat 30. Apr 2022, 11:11 Was mir in dem Zusammenhang einfällt: wenn du als Root eingeloggt bist bist mach mal ein "su -" und versuch das ganze nochmal.

Bin auch bei Hetzner :)
Was soll das bringen? Mit "id" sieht man die effektiven Rechten, root ist root, auch bei hetzner :)
Kann ich nicht bestätigen. Es ist ein Unterschied ob ich nur mit "su" versuche (bei mir in dem Fall Java) zu installieren oder mit "su -"
Da gab es auch Probleme mit den Zertifikaten. Erst nachdem ich ein "su -" eingegeben habe lief die Installaton von Java sauber durch.
Ach so, "su" vs "su -".

Das ist ganz einfch: "su" ändert nur die EUID (effective User ID). "su -" führt qusi eine login-shell aus, Du hast also die Umgebungsvariblen, z.B. sbin ist mit in den Pfaden. Also su meint im Prinzip immer "su -".
Use secondary nameservers with Keyhelp: https://24unix.net/projects/bindAPI
Supports DynDNS, documentation will be updated soon.

Are you looking for a PHP coder?
Or maybe a UNIX/Linux admin? I'm available for hire.
Post Reply