imagick und mailparse

Welche Features fehlen Ihnen noch? Teilen Sie es uns mit.
Post Reply
Linuxy95
Posts: 9
Joined: Mon 23. Jan 2023, 04:37

imagick und mailparse

Post by Linuxy95 »

Hallo Liebe Community,

Ich würde mich sehr freuen wenn das PHP Feature imagick und mailparse in Keyhelp implementiert wird.

Euch noch einen schönen Tag ;)

Grüße euer Linuxy95
User avatar
Alexander
Keyweb AG
Posts: 3109
Joined: Wed 20. Jan 2016, 02:23

Re: imagick und mailparse

Post by Alexander »

Hallo,

- Imagick ist bereits Teil der zusätzlich installierbaren PHP-Interpreter.

- Mailparse kann ich mir für den nächsten Kompiler-Lauf aufschreiben.
Mit freundlichen Grüßen / Best regards
Alexander Mahr

**************************************************************
Keyweb AG - Die Hosting Marke
Neuwerkstr. 45/46, 99084 Erfurt / Germany
http://www.keyweb.de - http://www.keyhelp.de
**************************************************************
Linuxy95
Posts: 9
Joined: Mon 23. Jan 2023, 04:37

Re: imagick und mailparse

Post by Linuxy95 »

Hallo Alexander,

in der php 8.1 Version sehe ich leider kein Support von imagick.

Grüße Linuxy95
User avatar
Alexander
Keyweb AG
Posts: 3109
Joined: Wed 20. Jan 2016, 02:23

Re: imagick und mailparse

Post by Alexander »

Welches OS kommt zum Einsatz?

Wir reden aber schon über die zusätzlich installierbaren PHP-Interpreter?
Mit freundlichen Grüßen / Best regards
Alexander Mahr

**************************************************************
Keyweb AG - Die Hosting Marke
Neuwerkstr. 45/46, 99084 Erfurt / Germany
http://www.keyweb.de - http://www.keyhelp.de
**************************************************************
Linuxy95
Posts: 9
Joined: Mon 23. Jan 2023, 04:37

Re: imagick und mailparse

Post by Linuxy95 »

Debian 11.6

ja genau.
User avatar
Florian
Keyweb AG
Posts: 789
Joined: Wed 20. Jan 2016, 02:28

Re: imagick und mailparse

Post by Florian »

Hallo,

kann ich nicht nachvollziehen auf Debian 11

Code: Select all

/opt/keyhelp/php/8.1/bin/php -m | grep imagick
imagick

Mit freundlichen Grüßen / Best regards
Florian Cheno

**************************************************************
Keyweb AG - Die Hosting Marke
Neuwerkstr. 45/46, 99084 Erfurt / Germany
http://www.keyweb.de - http://www.keyhelp.de
**************************************************************
Seklfreak
Posts: 25
Joined: Sat 9. Apr 2022, 20:30

Re: imagick und mailparse

Post by Seklfreak »

Um Florian zu bestätigen:

Code: Select all

root@server1:~# /opt/keyhelp/php/8.1/bin/php -m | grep imagick
imagick
root@server1:~#
Linuxy95
Posts: 9
Joined: Mon 23. Jan 2023, 04:37

Re: imagick und mailparse

Post by Linuxy95 »

Darf ich fragen warum bei Debian 11.6 mit Keyhelp Standard auf php 7.4 läuft?

Endet der Community Support von PHP 7.4 am 28. November 2022
Last edited by Linuxy95 on Thu 26. Jan 2023, 18:00, edited 1 time in total.
User avatar
Florian
Keyweb AG
Posts: 789
Joined: Wed 20. Jan 2016, 02:28

Re: imagick und mailparse

Post by Florian »

Hallo,

da fragst du am besten mal die Debian Maintainer, warum sie sich für diese Version entschieden haben.

Die Version wird vom BS geliefert und entsprechend mit Updates versorgt bis zum EOL von Debian 11
Mit freundlichen Grüßen / Best regards
Florian Cheno

**************************************************************
Keyweb AG - Die Hosting Marke
Neuwerkstr. 45/46, 99084 Erfurt / Germany
http://www.keyweb.de - http://www.keyhelp.de
**************************************************************
User avatar
24unix
Posts: 1041
Joined: Sun 21. Jun 2020, 17:16
Location: Kollmar
Contact:

Re: imagick und mailparse

Post by 24unix »

Florian wrote: Thu 26. Jan 2023, 17:48 da fragst du am besten mal die Debian Maintainer, warum sie sich für diese Version entschieden haben.
Bullseye wurde August 2021 released.

Aber der Code freeze begann schon früher: https://release.debian.org/bullseye/freeze_policy.html

Und da war PHP 8.0 vom November 2020 halt noch zu "frisch", die wenigsten Seiten darauf optimiert/geprüft.

Das hätte ein schönes Geschrei gegeben, wen Millionen von WP AddOns, phpBB-Extensionen und so weiter auf Bullseye explodiert wären.

Und da Debian schon immer recht konservativ war hat man sich halt für das stabile und verbreitete PHP 7.4 entschieden.

Wer wirklich (wie ich) Features von 8.0/8.1 nutzt, der kann sich die Pakete von Sury selber einspielen oder halt unter KH die Pakete von Alex, die auch immer zeitnah kommen.

Millionen von Usern ist die Version aber egal, solange die vorhandene Software weiterhin läuft.
mfg Micha
--
Backup: The duplicate copy of crucial data that no one bothered to make;
used only in the abstract
User avatar
24unix
Posts: 1041
Joined: Sun 21. Jun 2020, 17:16
Location: Kollmar
Contact:

Re: imagick und mailparse

Post by 24unix »

Linuxy95 wrote: Thu 26. Jan 2023, 17:45 Darf ich fragen warum bei Debian 11.6 mit Keyhelp Standard auf php 7.4 läuft?

Endet der Community Support von PHP 7.4 am 28. November 2022
Ja, das gilt, wenn man die offiziellen Pakete nutzt.
Sury z.B. pflegt die Sachen länger, bei Security-Problemen macht er Backports.

Das machen grundsätzlich immer alle Distributionen, darum ist es auch hüttendoof von Newsseiten zu sagen:
Paket x.y hat eine Schwachstelle, Versionen ab y.z. sind nicht mehr betroffen.

Der unbedarfte Jugadmin versucht dann mit Gewalt neue Versionen ins System zu spielen, obwohl die Pakte der Distributionen schon lange gefixed sind.
mfg Micha
--
Backup: The duplicate copy of crucial data that no one bothered to make;
used only in the abstract
Post Reply