Not receiving mail after upgrading to version 24.0 (Failed to start Interface between MTA and virus scanner/content filt  [SOLVED]

Have you discovered a bug? Tell us about it.
Post Reply
athensguy
Posts: 3
Joined: Sat 29. Feb 2020, 08:52

Not receiving mail after upgrading to version 24.0 (Failed to start Interface between MTA and virus scanner/content filt

Post by athensguy »

amavis service stopped and unable to restart and fails with below error Failed to start Interface between MTA and virus scanner/content filters.

Code: Select all

systemctl status amavis
× amavis.service - Interface between MTA and virus scanner/content filters
     Loaded: loaded (/lib/systemd/system/amavis.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Mon 2024-02-12 10:09:24 EET; 3s ago
       Docs: http://www.ijs.si/software/amavisd/#doc
    Process: 16398 ExecStartPre=/usr/bin/find /var/lib/amavis -maxdepth 1 -name amavis-* -type d -exec rm -rf {} ; (code=exited, status=0/SUCCESS)
    Process: 16399 ExecStartPre=/usr/bin/find /var/lib/amavis/tmp -maxdepth 1 -name amavis-* -type d -exec rm -rf {} ; (code=exited, status=0/SUCCESS)
    Process: 16400 ExecStart=/usr/sbin/amavisd-new foreground (code=exited, status=255/EXCEPTION)
   Main PID: 16400 (code=exited, status=255/EXCEPTION)
        CPU: 1.168s

Feb 12 10:09:24 Keyhelpsrv systemd[1]: amavis.service: Scheduled restart job, restart counter is at 5.
Feb 12 10:09:24 Keyhelpsrv systemd[1]: Stopped Interface between MTA and virus scanner/content filters.
Feb 12 10:09:24 Keyhelpsrv systemd[1]: amavis.service: Consumed 1.168s CPU time.
Feb 12 10:09:24 Keyhelpsrv systemd[1]: amavis.service: Start request repeated too quickly.
Feb 12 10:09:24 Keyhelpsrv systemd[1]: amavis.service: Failed with result 'exit-code'.
Feb 12 10:09:24 Keyhelpsrv systemd[1]: Failed to start Interface between MTA and virus scanner/content filters.
Checking mail log (hided yahoo email for privacy reasons)

Code: Select all

Feb 12 09:33:13 Keyhelpsrv postfix/smtp[6835]: 46A137E061: to=<#####@yahoo.com>, relay=none, delay=1704, delays=1704/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Simply nothing changed on server settings. It was only the update that break it down I think.

Please help me fix that
User avatar
Alexander
Keyweb AG
Posts: 3747
Joined: Wed 20. Jan 2016, 02:23

Re: Not receiving mail after upgrading to version 24.0 (Failed to start Interface between MTA and virus scanner/content

Post by Alexander »

Hello,

Please fill out the template for new topics in this forum the next time.
Otherwise a mod will very likly close the topic immediately.

---

You may want to try these commands:

Code: Select all

systemctl reset-failed amavis.service
systemctl start amavis.service
(viewtopic.php?p=37130#p37130)
Mit freundlichen Grüßen / Best regards
Alexander Mahr

**************************************************************
Keyweb AG - Die Hosting Marke
Neuwerkstr. 45/46, 99084 Erfurt / Germany
http://www.keyweb.de - http://www.keyhelp.de
**************************************************************
athensguy
Posts: 3
Joined: Sat 29. Feb 2020, 08:52

Re: Not receiving mail after upgrading to version 24.0 (Failed to start Interface between MTA and virus scanner/content

Post by athensguy »

Alexander wrote: Mon 12. Feb 2024, 12:41 Hello,

Please fill out the template for new topics in this forum the next time.
Otherwise a mod will very likly close the topic immediately.

---

You may want to try these commands:

Code: Select all

systemctl reset-failed amavis.service
systemctl start amavis.service
(viewtopic.php?p=37130#p37130)
I will consider using templates from now on.

The reset service command did not help
athensguy
Posts: 3
Joined: Sat 29. Feb 2020, 08:52

Re: Not receiving mail after upgrading to version 24.0 (Failed to start Interface between MTA and virus scanner/content   [SOLVED]

Post by athensguy »

Alex, thanks for your help.

After removing the amavis and re-install/configure, it works as expected.
Post Reply