Einen Überblick über das Administrationstool KeyHelp der Keyweb AG und dessen Download gibt es auf https://www.keyhelp.de

Dieses Forum soll es interessierten Benutzern ermöglichen, sich über KeyHelp auszutauschen und Hilfe bei Problemen zu finden.

HSTS Meldung von Firefox und Chrome  [GELÖST]

Fragen zur Benutzung oder Konfiguration
Antworten
Benutzeravatar
BloodOfPanda
Beiträge: 34
Registriert: Mi 6. Feb 2019, 21:46

HSTS Meldung von Firefox und Chrome

Beitrag von BloodOfPanda » Mi 4. Sep 2019, 10:40

Ein Hallo in die Runde,

ich habe zu meiner test.domain.dev kein SSL Zertifikat hinterlegt und auch kein HSTS aktiviert, dennoch bekomme ich von den Browsern die Meldung das es so wäre. Auch bei der dazugehörigen Hauptdomain ist HSTS nicht aktiviert lediglich Let's Encrypt SSL ist aktiv.


Bild
https://bruzzlers.de/images/bild5.png (Das zweite Bild war mir zu groß daher als Link :))

Ich habe verschiedene Browser genutzt und auch den Cache dieser gelöscht. Ohne erfolg. Auch auf einem Rechner der noch nie auf der Seite war bekommt man die gleiche Meldung. Nehme ich eine andere Domain geht es wunderbar.

Hat jemand ne Idee wo es hängen könnte bzw. in welchen Logs ich dazu was lesen könnte?

Grüße Marcel
mhagge
Beiträge: 99
Registriert: Mi 8. Aug 2018, 15:19

Re: HSTS Meldung von Firefox und Chrome  [GELÖST]

Beitrag von mhagge » Mi 4. Sep 2019, 11:18

Hallo Marcel,

für .dev-Domains ist automatisch schon von Seiten der Registry HSTS aktiviert (siehe z.B. hier: https://t3n.de/news/dev-tlds-sind-jetzt ... r-1147633/ ). Es macht also keinen Sinn, dort kein SSL/HSTS zu aktivieren bzw. führt dann zu beschriebenem Problem.

Viele Grüße
Markus
Benutzeravatar
Tobi
Beiträge: 960
Registriert: Do 5. Jan 2017, 13:24

Re: HSTS Meldung von Firefox und Chrome

Beitrag von Tobi » Mi 4. Sep 2019, 11:55

Ich meine sogar gelesen zu haben, dass .dev - Domains _zwingend_ ein gültiges Zertifikat haben _müssen_!
Gruß,
Tobi



https://wewoco.de
webworkercommunity forum
Benutzeravatar
Martin
Keyweb AG
Beiträge: 726
Registriert: Mi 20. Jan 2016, 00:43

Re: HSTS Meldung von Firefox und Chrome

Beitrag von Martin » Mi 4. Sep 2019, 11:59

Hallo,

das bedingt sich ja aus HSTS, interessant zu wissen das dies bei diesen Domains erzwungen wird.
Mit freundlichen Grüßen / Best regards
Martin Dannehl

**************************************************************
Keyweb AG - Die Hosting Marke
Neuwerkstr. 45/46, 99084 Erfurt / Germany
http://www.keyweb.de - http://www.keyhelp.de
**************************************************************
Benutzeravatar
BloodOfPanda
Beiträge: 34
Registriert: Mi 6. Feb 2019, 21:46

Re: HSTS Meldung von Firefox und Chrome

Beitrag von BloodOfPanda » Mi 4. Sep 2019, 13:45

mhagge hat geschrieben:
Mi 4. Sep 2019, 11:18
Hallo Marcel,

für .dev-Domains ist automatisch schon von Seiten der Registry HSTS aktiviert (siehe z.B. hier: https://t3n.de/news/dev-tlds-sind-jetzt ... r-1147633/ ). Es macht also keinen Sinn, dort kein SSL/HSTS zu aktivieren bzw. führt dann zu beschriebenem Problem.

Viele Grüße
Markus
Tobi hat geschrieben:
Mi 4. Sep 2019, 11:55
Ich meine sogar gelesen zu haben, dass .dev - Domains _zwingend_ ein gültiges Zertifikat haben _müssen_!
Ihr habt natürlich recht... Und ich habe das komplett vergessen, dass es so ist.

Als die .dev Domains zum Kauf rausgekommen sind, haben wir noch in nem anderen Forum da drüber diskutiert und ich meinte noch "Ist ja nicht schlimm hab ja so oder so HTTPS aktiv". Nun brauchte ich, aber zum Testen einer Funktion von nem DrayTek Router eine Seite die unverschlüsselt ist und ich dachte mir "Hey wie praktisch ich hab ja meine .dev Domain dafür die kann ich ja gleich dazu benutzten xD".

Vielen Dank für die Rückmeldungen ist damit gelöst.
Antworten

Wer ist online?

Mitglieder in diesem Forum: Majestic-12 [Bot] und 3 Gäste